Watershed

Application degradation
Resolved·Partial outage

The incident is resolved.

Thu, Jun 12, 2025, 10:39 PM
(2 weeks ago)
·
Affected components
Application
API
SSO
Updates

Resolved

The incident is resolved.

Thu, Jun 12, 2025, 10:39 PM

Monitoring

We are seeing full recovery on all services and are continuing to monitor.

Thu, Jun 12, 2025, 10:08 PM(31 minutes earlier)

Monitoring

SSO has recovered. We continue to see minor degradation across the product and are monitoring for recovery.

Thu, Jun 12, 2025, 08:26 PM(1 hour earlier)

Identified

While some Watershed product functionality is recovering, the incident is ongoing. SSO continues to be affected. We are continuing to monitor for recovery with upstream providers.

Thu, Jun 12, 2025, 07:59 PM(26 minutes earlier)

Identified

We have identified upstream providers as the source of the issue and are monitoring for recovery.

Thu, Jun 12, 2025, 06:58 PM(1 hour earlier)

Investigating

We are currently investigating an issue affecting application availability and login.

Thu, Jun 12, 2025, 06:32 PM(25 minutes earlier)
Powered by