Watershed

File uploads hanging
Resolved·Partial outage

This incident has been resolved.

Mon, Sep 29, 2025, 07:31 PM
(2 weeks ago)
·
Affected components
Application
Updates

Resolved

This incident has been resolved.

Mon, Sep 29, 2025, 07:31 PM

Monitoring

We're continuing to monitor but have seen no further issues.

Mon, Sep 29, 2025, 06:34 PM(57 minutes earlier)

Monitoring

The underlying issue has been resolved and uploads are now succeeding. Uploads that were hung during the degradation and did not experience an error are also completing. We are monitoring the results.

Mon, Sep 29, 2025, 05:41 PM(52 minutes earlier)

Identified

We've identified an issue with file uploads hanging indefinitely in the product in the US region. Uploading data via the API is unaffected. We're working on resolving this issue.

Mon, Sep 29, 2025, 05:30 PM(10 minutes earlier)
Powered by