Watershed

Watershed application currently unavailable due to outage of upstream provider
Resolved·Full outage

The incident is resolved (this update is retroactive).

Mon, Dec 8, 2025, 10:58 PM
(6 days ago)
·
Affected components
Application
API
SSO
Updates

Resolved

The incident is resolved (this update is retroactive).

Mon, Dec 8, 2025, 10:58 PM

Monitoring

Cloudflare have resolved their issue and the Watershed application is available again.

Fri, Dec 5, 2025, 09:13 AM(3 days earlier)

Investigating

Attempts to access the Watershed application shows a cloudflare error stopping access to the site.

Fri, Dec 5, 2025, 09:06 AM
Powered by