Watershed

Facilities tab shows error
Resolved·Degraded performance

The facilities tab is now functioning again.

Thu, Feb 5, 2026, 10:13 AM
(1 week ago)
·
Affected components
Application
Updates

Resolved

The facilities tab is now functioning again.

Thu, Feb 5, 2026, 10:13 AM

Investigating

The facilities tab in measurement projects shows an error. Users can continue to manage facilities through project tasks.

We are currently investigating the issue.

Thu, Feb 5, 2026, 09:33 AM(39 minutes earlier)
Powered by